You are here

Hungabee

Software Available on Hungabee

Title Version Usage Notes
64-bit SLES 11 SP1 2.6.32.54-0.3-default
ABySS 1.5.2

module load application/ABySS/1.5.2

ABySS 1.3.2

module load application/ABySS/1.3.2

ABySS 1.5.1

module load application/ABySS/1.5.1

ABySS 1.3.5

module load application/ABySS/1.3.5

ALLPATHS-LG Revision 43500

module load application/allpathslg/43500

ALLPATHS-LG Also available: 42069
ALLPATHS-LG Also available: 40691
ALLPATHS-LG 49962

application/allpathslg/49962

Augustus 2.5.5

module load application/augustus/2.5.5

bamUtil 1.0.13

module load application/bamutil/1.0.13

BCFtools (VCF/BCF file manipulation) 1.3

module load application/bcftools/1.3   

BEDTools 2.26.0

module load application/bedtools/2.26.0 

BLAS In MKL
BLAST ncbi-blast-2.2.28+

module load application/blast/2.2.28

BLAST ncbi-blast-2.2.29+

module load application/blast/2.2.29

BLAST ncbi-blast-2.6.0+

module load application/blast/2.6.0

BLAST 2.2.31+

module load application/blast/2.2.31

BLAT 3.5

module load application/blat/3.5

Boost 1.49.0

module load library/boost/1_49_0

Boost 1.60.0 (gcc52)

module load library/boost/1_60_0

Boost 1.54.0

Initialize your environment to use Boost 1.54.0 with

module load library/boost/1_54_0

Bowtie 0.12.8

module load application/bowti /0.12.8

Bowtie 1.0.0

module load application/bowtie/1.0.0

Bowtie2 2.0.0

module load application/bowtie2/2.1.0

Bowtie2 2.2.2

module load application/bowtie2/2.2.2

BWA 0.6.2

module load application/bwa/0.6.2

BWA 0.7.12

module load application/bwa/0.7.12

C - GNU GCC, Intel, Portland Group (PGI) compilers Portland Group 13.9

(pgcc - module load compiler/pgi/13.9)

C - GNU GCC, Intel, Portland Group (PGI) compilers Intel 12.1.5

(icc, module load compiler/ intel/12.1, loaded by default)

C - GNU GCC, Intel, Portland Group (PGI) compilers Portland Group 12.10

(pgcc - module load compiler/pgi/12.10)

C - GNU GCC, Intel, Portland Group (PGI) compilers GNU 4.5.0

(gcc - module load compiler/gcc/4.5.0)

C - GNU GCC, Intel, Portland Group (PGI) compilers GNU 4.3.4

(gcc)

C - GNU GCC, Intel, Portland Group (PGI) compilers GNU 4.8.3

module load compiler/gcc/4.8.3

C++ - GNU GCC, Intel, Portland Group (PGI) compilers Portland Group 13.9

(pgCC - module load compiler/pgi/13.9)

C++ - GNU GCC, Intel, Portland Group (PGI) compilers Intel 12.1.5

(icpc, module load compiler/ intel/12.1, loaded by default)

C++ - GNU GCC, Intel, Portland Group (PGI) compilers Portland Group 12.10

pgCC
module load compiler/pgi/12.10

C++ - GNU GCC, Intel, Portland Group (PGI) compilers GNU 4.5.0

(g++ - module load compiler/gcc/4.5.0)

C++ - GNU GCC, Intel, Portland Group (PGI) compilers GNU 4.3.4

(g++)

C++ - GNU GCC, Intel, Portland Group (PGI) compilers GNU 4.8.3

module load compiler/gcc/4.8.3

CAP3 02-10-15

module load application/CAP3/02-10-15 

Cd-hit v4.6.4-2015-0603

module load application/cd-hit/v4.6.4-2015-0603

Cd-hit v4.6.1-2012-08-27

module load application/cd-hit/v4.6.1-2012-08-27

Celera Whole-Genome Shotgun Assembler 7.0

module load application/wgs/7.0

Chaste 3.4

module load application/chaste/release_3.4

Chaste 3.1

module load application /chaste /release_3.1

CMake 2.8.10.2

module load utility/cmake/2.8.10.2

Compilers - C, C++ and Fortran GCC 4.3.4

The GCC 4.3.4 compilers are on the default command PATH.

Compilers - C, C++ and Fortran GCC 4.5.0

Initialize your environment to use the GCC 4.5.0 compilers with

module load compiler/gcc/4.5.0

Compilers - C, C++ and Fortran GCC 4.8.3

Initialize your environment to use the GCC 4.8.3 compilers with

module load compiler/gcc/4.8.3

Compilers - C, C++ and Fortran GCC 4.9.2

Initialize your environment to use the GCC 4.9.2 compilers with

module load compiler/gcc/4.9.2

Compilers - C, C++ and Fortran Intel 12.1.5

The Intel 12.1.5 compilers are on the default command PATH, but, you can also explicitly initialize your environment to use them with

module load compiler/intel/12.1

Compilers - C, C++ and Fortran PGI 12.10-0

Initialize your environment to use the Portland Group 12.10-0 compilers with

module load compiler/pgi/12.10

Compilers - C, C++ and Fortran PGI 13.9-0

Initialize your environment to use the Portland Group 13.9-0 compilers with

module load compiler/pgi/13.9

CP2K 3.0

module load application/cp2k/3.0

CPMD 3_15_3

module load application/cpmd/v3_15_3

csh Link to tcsh
Cufflinks 2.2.1

Set up your environment to use Cufflinks 2.2.1 with:

module load application/cufflinks/2.2.1

Emacs 22.3.1
ESTScan 2.1

module load application/estscan/2.1

Exonerate 2.2.0

module load application/exonerate/2.2.0

Eye of GNOME 2.28.2
FastQC 0.11.3

module load application/fastqc/0.11.3

FEniCS DOLFIN 1.1.0

module load application /dolfin/1.1.0

FFTW 3.3.1

module load library/fftw/3.3.1

Fortran - GNU GCC, Intel, Portland Group (PGI) and Absoft compilers Portland Group 12.10

(pgf77, pgf90, pgf95 - module load compiler/pgi/12.10)

Fortran - GNU GCC, Intel, Portland Group (PGI) and Absoft compilers GNU 4.8.3

module load compiler/gcc/4.8.3

Fortran - GNU GCC, Intel, Portland Group (PGI) and Absoft compilers GNU 4.5.0

(gfortran - module load compiler/gcc/4.5.0)

Fortran - GNU GCC, Intel, Portland Group (PGI) and Absoft compilers GNU 4.3.4

(gfortran)

Fortran - GNU GCC, Intel, Portland Group (PGI) and Absoft compilers Portland Group 13.9

(pgf77, pgf90, pgf95 - module load compiler/pgi/13.9)

Fortran - GNU GCC, Intel, Portland Group (PGI) and Absoft compilers 12.1.5

ifort, module load compiler/ intel/12.1, loaded by default

freebayes 1.0.2

module load application/freebayes/1.0.2

GATK 3.7

module load application/gatk/3.7 

GATK 3.5

module load application/gatk/3.5

gatk.sh -Xmx1g -Xms1g --help

Gaussian G09 B.01

For U of A researchers only.  Initialize your environment with:

module load uofa/gaussian/g09-b1

Gaussian G09 D.01

For U of A researchers only.  Initialize your environment with:

module load uofa/gaussian/g09-d1

gdb 7.3-0.6.1
gedit - graphical text editor 2.28.3

See general gedit usage notes.

Git 1.6.0.2
GMAP (with GSNAP) - Genomic mapping and alignment 2014-12-02

module load application/gmap/2014-12-02

GMAP (with GSNAP) - Genomic mapping and alignment 2017-04-13

module load application/gmap/2017-04-13

Gnuplot 4.2
GROMACS 4.5.5

Initialize the environment with module load application/gromacs/4.5.5 .

GSL 1.16

module load library/gsl/1.16

HDF 5 1.8.8

module load library/hdf5/1.8.8

hisat2 2.0.4

module load application/hisat2/2.0.4

HMMER 3.1b1

module load application/hmmer/3.1b1

Homer 4.8.3

module load application/homer/4.8.3

idb 12.1

module load compiler/intel/12.1

ImageMagick 6.4.3
IQ-TREE (phylogenetics) 1.3.2

Initialize your environment to use IQ-TREE 1.3.2 on Hungabee with:

module load application/iq_tree/1.3.2  

IQ-TREE (phylogenetics) 1.3.1

Initialize your environment to use IQ-TREE 1.3.1 on Hungabee with:

module load application/iq_tree/1.3.1

JAGS 4.2.0

module load application/jags/4.2.0

Jam 3.1.16
Java Oracle JDK 1.8.0 update 92

module load application/jdk/1.8.0_92

Java Java 1.6.0_25
JELLYFISH 1.1.11

module load application/jellyfish/1.1.11        

Julia 0.3

module load application/julia/0.3

Julia 0.5.0

module load application/julia/0.5.0

Kraken 0.10.6-beta

module load application/kraken/0.10.6-beta 

minikraken database in /global/software/kraken/db/minikraken_20141208

ksh Y
LAPACK In MKL
LibYAML 0.14

module load library/yaml/0.1.4

Mathematica 8.0

U of A only

module load uofa/Mathematica/8.0

MATLAB R2013a module load uofa/matlab/R2013a

(UofA only)
MEGAHIT 1.1.1

module load application/megahit/1.1.1

Minia 2.0.7

module load application/minia/v2.0.7

MKL In Intel 12 environment
Mothur 1.39.5

module load application/mothur/1.39.5

Mothur 1.32.1

module load application/mothur/1.32.1

nano 2.2.6
Nektar++ 3.2.0

module load application /nektar++/3.2.0

NetCDF 4.1.3 module load library/netcdf/4.1.3

$NETCDFHOME
NetworkX 1.7

module load application/python/2.7.3

NWChem 6.1.1

module load application/nwchem/6.1.1

Parallel 20150922

module load application/parallel/20150922

Perl 5.10.0
PETSc 3.4.5

module load application/petsc/3.4.5

PETSc 3.5.3

application/petsc/3.5.3

Picard tools 1.60

/global/software/picard-tools/picard-tools-1.60

Picard tools 1.98

Set up your environment with:

module load application/picard-tools/1.98

This sets various aliases. To see them, type

module show application/picard-tools/1.98

Picard tools 2.9.0

module load application/picard-tools/2.9.0

Picard tools 2.1.1

module load  application/picard-tools/2.1.1

picard -h

Python 3.4.2

module load application/python/3.4.2

Python Anaconda 2.3.0

module load application/anaconda/2.3.0 

Python 2.7.3

Initialize your environment with:

module load application/python/2.7.3

This installation includes NumPy 1.6.2 and SciPy 0.11.0.

Python 2.6

(default)

R 3.1.2

module load application/R/3.1.2

R 3.0.1

module load application/R/3.0.1

R 3.2.5

Set up your environment to use R 3.2.5 on Hungabee with

module load application/R/3.2.5

R 3.3.2

module load application/R/3.3.2

R 2.15.0

module load application/R/2.15.0

Ray 2.3.1

module load application/Ray/2.3.1

(MAXKMERLENGTH=399)

Relion 1.3

module load application/relion/1.3

RepeatMasker open-4-0-3

module load application/repeatmasker/open-4-0-3

RMBlast 2.2.28

module load application/rmblastn/2.2.28

RNAmmer 1.2

module load application/rnammer/1.2

RSEM 1.2.7

module load application/rsem/1.2.7

RSEM 1.2.21

module load application/rsem/1.2.21

Ruby 1.8.7
SAMtools and HTSlib utilities 1.4

module load application/samtools/1.4

SAMtools and HTSlib utilities 0.1.19

Initialize the environment with module load application/samtools/0.1.19.

SAMtools and HTSlib utilities 1.3

module load application/samtools/1.3

SAMtools and HTSlib utilities 0.1.18

Initialize the environment with module load application/samtools/0.1.18.

ScaLAPACK MKL

ScaLAPACK is available through the Math Kernel Library (MKL).

sh Link to bash
SignalP 4.1c

module load application/signalp/4.1c

SNAP 2013-02-16

module load application/snap/2013-02-16

SOAPdenovo-Trans 1.02

module load application/SOAPdenovo-Trans/1.02

SPAdes Genome Assembler 3.6.1

module load application/SPAdes/3.6.1

SPAdes Genome Assembler 3.10.0

module load application/SPAdes/3.10.0

SPAdes Genome Assembler 3.10.1

To use SPAdes 3.10.1 on Hungabee, initialize your environment with

module load application/SPAdes/3.10.1

Stacks 1.25

module load application/stacks/1.25

Structure 2.3.4

Either one of

module load application/structure/2.3.4

or

application/structure-frontend/2.3.4

Subversion 1.5.7
Swig 2.0.9

module load application/swig/2.0.9

Tandem Repeats Finder 407b

module load application/trf/407b

tcsh NA
TMHMM 2.0c

module load application/tmhmm/2.0c

TopHat 2.0.14

module load application/tophat/2.0.14

Trans-ABySS 1.5.2

module load application/Trans-ABySS/1.5.2 

Trans-ABySS 1.5.1

module load application/Trans-ABySS/1.5.1

Trans-ABySS 1.5.5

module load application/Trans-ABySS/1.5.5

TransDecoder 3.0.1

module load application/transdecoder/3.0.1

TransDecoder 2.0.1

module load application/transdecoder/2.0.1

Trimmomatic 0.33

See instructions on the WestGrid Trimmomatic page.

Trinity r2013-02-25

application/trinity/r2013-02-25

Trinity r20140413p1

module load application/trinity/r20140413p1

Trinity 2.2.0

Set up your enivronment to use Trinity 2.2.0 with

module load application/trinity/2.2.0

Trinity 2.1.1

module load application/trinity/2.1.1

Trinity 2.3.2

module load application/trinity/2.3.2

Trinity 2.4.0

module load application/trinity/2.4.0

Trinity 2.0.6

module load application/trinity/2.0.6

Trinity 2012-06-08

module load application/trinity/r2012-06-08

Trinity 2012-10-05

module load application/trinity/r2012-10-05

Trinotate 2.0.2

module load application/trinotate/2.0.2

Trinotate 3.0.1

module load  application/trinotate/3.0.1

Trinotate r20131110

module load application/trinotate/r20131110

VarSim 0.5.1

module load application/varsim/0.5.1

VCFtools 0.1.10

Initialize your environment with

module load application/vcftools/0.1.10

Note, the VCFtools Perl utilities were not installed.

Velvet 1.2.03

module load application/velvet/1.2.03

Vim 7.2
VMD 1.9.2

module load application/vmd/1.9.2

VTK - Visualization Toolkit 5.10.1

module load application/vtk/5.10.1

WebLogo 2.8.2

module load  application/weblogo/2.8.2